Author Topic: SMF errors in error log  (Read 4686 times)

Nax

  • Jr. Member
  • **
  • Posts: 19
SMF errors in error log
« on: March 01, 2010, 06:32:54 PM »
I notice that my error log is full of items relating to SMF:-

Mon Mar 01 09:33:32 2010] [error] [client xx.xx.xx.xx] File does not exist: /home/mysite/public_html/404.shtml, referer: http://www.mysite.com/funforest/index.php?action=post;topic=5.0;num_replies=4749
[Mon Mar 01 09:33:32 2010] [error] [client xx.xx.xx.xx] File does not exist: /home/mysite/public_html/funforest/Themes/brightforest_21/images/bbc/spoiler.gif, referer: http://www.mysite.com/funforest/index.php?action=post;topic=5.0;num_replies=4749


The files being reported as not existing do exist - is there a problem with my set-up?  I did submit a ticket but it was closed without a reply.  I am using SMF v2

SunKing

  • G.C. Support
  • Jr. Member
  • ***
  • Posts: 24
    • Empire of the Sun
Re: SMF errors in error log
« Reply #1 on: March 01, 2010, 07:11:36 PM »
Can you post or PM me a link to your site? Are any errors showing up in other places on your site, such as when you try to post, etc.

Nax

  • Jr. Member
  • **
  • Posts: 19
Re: SMF errors in error log
« Reply #2 on: March 02, 2010, 04:14:37 PM »
Well the theme setting are as follow (my domain renamed to mydomain):-

Theme directory (templates):/home/mydomain/public_html/funforest/Themes/brightforest_21
URL to above directory:http://www.mydomain.com/funforest/Themes/brightforest_21
URL to images directory:http://www.mydomain.com/funforest/Themes/brightforest_21/images

As far as I can se this looks correct.

The base path to the themes directory is - /home/mydomain/public_html/funforest/Themes

The BASE URL to the same directory is - http://www.mydomain.com/funforest/Themes

SunKing

  • G.C. Support
  • Jr. Member
  • ***
  • Posts: 24
    • Empire of the Sun
Re: SMF errors in error log
« Reply #3 on: March 02, 2010, 07:28:19 PM »
The paths all seem correct from a settings standpoint. I think the image in question is actually missing from your theme's images/bbc/ folder. If you navigate to http://www.yoursite.com/funforest/Themes/brightforest_21/images/bbc/quote.gif, you'll see the quote.gif in your browser. However, if you change that to http://www.yoursite.com/funforest/Themes/brightforest_21/images/bbc/spoiler.gif, you'll receive a 404 error (not found). Open your /Themes/brightforest_21/images/bbc/ folder and verify that there is indeed a spoiler.gif in there.

Adding the image to that folder should take care of both of the errors you are getting. If you need further assistance, please do not hesitate to ask.

Nax

  • Jr. Member
  • **
  • Posts: 19
Re: SMF errors in error log
« Reply #4 on: March 03, 2010, 09:02:55 AM »
Yes I see that, thanks! I'm not sure why this did not get installed as it was a mod and it seems to have worked ok  on my test forum running on my laptop.  I'll review the eror log again to see if there is anything else that seems to be in the wrong place.

Cheers.