Author Topic: PHP Version and SMF software  (Read 6631 times)

crash56

  • Hero Member
  • *****
  • Posts: 143
PHP Version and SMF software
« on: December 06, 2013, 03:24:39 AM »
I was over at the SMF forum, and wound up reading about the "end of life" of SMF version 1.1.x, and upcoming versions of PHP.  The thread said that PHP 5.5 may break a forum that is running on SMF 1.1.19 and that PHP 5.6 would almost certainly break it.

According to my control panels, GCS is currently running PHP 5.4.19.  Do you have any guesstimate when PHP 5.5 might come along?  I'm wondering how much time (weeks, months, years) I have to work on themes and such for my forums.

Thanks!

G.C. Admin

  • Performance Based Hosting
  • Administrator
  • Hero Member
  • *****
  • Posts: 990
Re: PHP Version and SMF software
« Reply #1 on: December 06, 2013, 05:59:44 AM »
HI,

Switching PHP versions is a very delicate issue, As many different types of software run on our servers. And a lot of times it not the software but the plugins that cause the issues with a PHP version shift. Chances are unless the version needs to be upgraded due security reasons . I generally wait 8-12 months after the newest release. PHP 5.5.2 being released in 16-Aug-2013

Frank
Frank Doud
Owner/Operator
G.C. Solutions

crash56

  • Hero Member
  • *****
  • Posts: 143
Re: PHP Version and SMF software
« Reply #2 on: December 06, 2013, 10:05:13 AM »
Thanks. 

Guess I ought to finally upgrade to SMF 2.0.x ... kicking, and screaming, and resisting (but only because I don't want to rebuild our custom themes).   ;)

G.C. Admin

  • Performance Based Hosting
  • Administrator
  • Hero Member
  • *****
  • Posts: 990
Re: PHP Version and SMF software
« Reply #3 on: December 07, 2013, 01:39:16 AM »
Thanks. 

Guess I ought to finally upgrade to SMF 2.0.x ... kicking, and screaming, and resisting (but only because I don't want to rebuild our custom themes).   ;)

Everyone should upgrade to 2.0........   :D
Frank Doud
Owner/Operator
G.C. Solutions

crash56

  • Hero Member
  • *****
  • Posts: 143
Re: PHP Version and SMF software
« Reply #4 on: December 07, 2013, 03:47:17 PM »
Everyone should upgrade to 2.0........   :D

Yeah.  I know I've been putting it off.  I just hate rebuilding themes because I don't really know what I'm doing. 

I just began work getting the first of my forums (the smaller one) ready for the change over.  *snivelwhinegripemoangrouse*

crash56

  • Hero Member
  • *****
  • Posts: 143
Re: PHP Version and SMF software
« Reply #5 on: December 07, 2013, 05:04:11 PM »
Hey, Frank?  Question about installing two forums on the same site. 

I installed a test forum where I could experiment with the upgrade.  It was (past tense, it's gone) at the same level of my directory as my usual forum ... so one forum was at /Feedback and the other was at /forum.  I used separate databases (naturally).  I made some changes to the test forum to make sure everything was connected correctly.  Then, when I began the upgrade from 1.1.19 to 2.0.6 on my test forum, it began affecting my active forum.  In the end, I had to delete the test forum (/forum) and run repair_settings.php to restore Feedback.  (And then ran over to the electrical outlet and gave myself a jolt to get my heart started again). 

Can I not run two forums like this?  I thought as long as they were connected to separate databases I could do this.  I figure I screwed something up along the way, and it was my mistake, but I wanted to check before I give myself another heart attack.  ;)

crash56

  • Hero Member
  • *****
  • Posts: 143
Re: PHP Version and SMF software
« Reply #6 on: December 07, 2013, 07:28:55 PM »
Disregard my last.  Found the problem.  Yup.  It was me.   :P  ...   ;D